As of December 1st, 2015 the minimum PHP version required to run ZenCache will be changed from PHP 5.3.2+ to PHP 5.4+. If your server is currently running PHP 5.3, you will need to upgrade to PHP 5.4 or higher to continue running the latest version of ZenCache. PHP 5.3 has been unsupported for over a year now and no longer receives security updates or bug fixes, so upgrading is highly recommended. WordPress.org recommends PHP 5.6 or higher.
Staying with a lower PHP minimum version requirement prevents us from innovating and continuing to build a better product and by increasing the minimum PHP version requirement, we'll be able to offer new features, an improved codebase, and greater reliability and compatibility with other WordPress software.
What is PHP?
PHP is a scripting language that runs on web servers and powers many web applications, including WordPress and ZenCache. Like other software, PHP gets updated over time to patch security issues and improve its features. As with other software, it's very important to keep your PHP version up to date. At the time of this writing, PHP 5.5 is the lowest supported and maintained version of PHP.
PHP 5.3 End-of-Life (EOL)
PHP 5.3 reached its End-of-Life (EOL) over a year ago, on August 14th, 2014. That means PHP 5.3 is currently unsupported and running PHP 5.3 exposes your server to security vulnerabilities and bugs. If your server is running an unsupported PHP release, you are strongly urged to upgrade to a current version (or request that your web hosting company upgrade your server), as using older versions of PHP may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.
In fact, even PHP 5.4 has reached its EOL (September 14th, 2015) so if you need to upgrade your server, we highly recommend upgrading straight to PHP 5.5 or higher. WordPress.org recommends PHP 5.6 or higher.
The PHP website includes a page that shows the current status of PHP 5.3, 5.4, 5.5, and 5.6:
How do I upgrade to PHP 5.4 or higher?
PHP is software that runs on your website's server, so you'll most likely need to contact your web hosting company and ask them to upgrade PHP on your server. Here's a letter you can send your web hosting company:
Dear web host,
I'm running a WordPress website on one of your servers and one of the plugins (ZenCache) requires PHP 5.4 or higher. WordPress, the CMS that ZenCache runs on, has listed PHP 5.6 as the recommended PHP version on their requirements page: https://wordpress.org/about/requirements/
Can you please upgrade my hosting to PHP 5.4 or higher?
I look forward to your reply.
What if I cannot upgrade to PHP 5.4?
If your web hosting company does not support PHP 5.4 or higher, or if they're unwilling to upgrade your account, we recommending finding a web host that does support PHP 5.4 or higher. All of the web hosts recommended by WordPress support PHP 5.6 or higher.
Why is ZenCache requiring PHP 5.4 or higher?
We are changing the minimum PHP version to 5.4 because staying with a lower PHP minimum version requirement prevents us from innovating and continuing to build a better product.
How can I run ZenCache on PHP 5.3?
If you want to continue using PHP 5.3, you can download a previous version of ZenCache from the ZenCache Release Archive that runs on PHP 5.3.